Agent installation fails - No recipes were installed

Hi there! I am trying to install the infra-agent on Ubuntu 20.04.
And I am receive this error:

| \ | | _____      __ |  _ \ ___| (_) ___
|  \| |/ _ \ \ /\ / / | |_) / _ | | |/ __|
| |\  |  __/\ V  V /  |  _ |  __| | | (__
|_| \_|\___| \_/\_/   |_| \_\___|_|_|\___|

Welcome to New Relic. Let's set up full stack observability for your environment. 

✔ Connecting to New Relic Platform.. 
   Connected 


Installing New Relic
  --------------------
  Installation Summary

  ⊘  Infrastructure Agent  (unsupported)  

  Installation incomplete. Follow the instructions at the URL below to complete the installation process. 

  ⮕  https://onenr.io/0bRmDZ7W9wy

  --------------------

We encountered an issue during the installation: no recipes were installed.
If this problem persists, visit the documentation and support page for additional help here at https://one.newrelic.com/-/06vjAeZLKjP.

Any idea what it could be?

Hi, @rodrigo22: If the guided install fails, you might try the step-by-step instructions here: Install the infrastructure monitoring agent for Linux | New Relic Documentation.

Did you manage to find a solution?

I’m getting the same error here. Have trying to manually install with the step by step instructions for Centos 7, and get the error:

no package newrelic-infra available

Hi, @atendimento10: I just installed the agent on CentOS 7 without error. Did you remember to add the infrastructure monitoring agent repository and refresh the repositories?

https://docs.newrelic.com/docs/infrastructure/install-infrastructure-agent/linux-installation/install-infrastructure-monitoring-agent-linux#centos-rhel-repository

Helli @philweber.

Yes, I followed all the steps of the Step-by-step instructions.
At the end of installation, I get the results:

Total download size: 39 M
Installed size: 113 M
Downloading packages:
newrelic-infra-1.24.2-1.el7.x86_64.rpm | 39 MB 00:00:03
Running transaction check
Running transaction test
Transaction test succeeded
Running transaction
Installing : newrelic-infra-1.24.2-1.el7.x86_64 1/1C
reated symlink from /etc/systemd/system/multi-user.target.wants/newrelic-infra.service to /etc/systemd/system/newrelic-infra.service.
Verifying : newrelic-infra-1.24.2-1.el7.x86_64 1/1

Installed: newrelic-infra.x86_64 0:1.24.2-1.el7

Complete!

However, when I run sudo systemctl status newrelic-infra, I get the results:

● newrelic-infra.service - New Relic Infrastructure Agent
Loaded: loaded (/etc/systemd/system/newrelic-infra.service; enabled; vendor preset: disabled)
Active: activating (auto-restart) (Result: exit-code) since Sun 2022-05-08 13:20:54 UTC; 5s ago
Process: 6805 ExecStart=/usr/bin/newrelic-infra-service (code=exited, status=1/FAILURE)
Main PID: 6805 (code=exited, status=1/FAILURE)

May 08 13:20:54 node25800-env-4356852.jelastic.saveincloud.net systemd[1]: Unit newrelic-infra.service entered failed state.
May 08 13:20:54 node25800-env-4356852.jelastic.saveincloud.net systemd[1]: newrelic-infra.service failed.
Warning: Journal has been rotated since unit was started. Log output is incomplete or unavailable.

@philweber, I’ve managed to fix the issue.
I’ve executed nrdiag --suites infra, and got the result:

Failure - Base/Config/Validate
Errors parsing the following 1 configuration file(s):
/etc/newrelic-infra.yml
Error: yaml: unmarshal errors:
line 2: mapping key “xxx” already defined at line 1.
This can mean that you either have incorrect spacing/indentation around this line or that you have a syntax error, such as a missing/invalid character
See https://docs.newrelic.com/docs/agents/manage-apm-agents/configuration/configure-agent for more information.

For some reason, the first time I uninstalled Newrelic-Infra, the file newrelic-infra.yml was not deleted, and when I did the step by step installation, it added another license key line to it.

I’ve corrected the file and the installation was successfully.

Thanks you.

1 Like