Agent still running, but I can't find it to remove it from the host it may be running on

I’d like for my New Relic dashboard to be clear, and I don’t want any agents running on my hosts currently. I’ve done some research to see how to uninstall these agents, but I’m stuck now.

Hi @derek.lyons!

Thank you for reaching out to the Explorer’s Hub! Can you confirm that you followed the steps listed here? Let me know how it works out for you.

1 Like

Sure, I will try that and confirm I’ve followed the steps, however a challenge that I have, is that I don’t know what host / application this is for. As you can see it’s just called “My Application” and from the poking around I’ve done, I can’t tell what host or application it actually is for.

Hi @derek.lyons ,

To identify the host on which your application is running, please click on the application name in the APM list and scroll down.
At the end of Summary page, you will see a section where Host and Instances are listed.

Also please review this document, it might help you:

I hope it will help, let us know if you need additional assitance.

Thanks.

KR,
Marin

1 Like

Thank you!

I think I found the section you are talking about. What’s strange is this application actually shows 0 hosts and 0 instances, but it remains in my dashboard. I will upload a screenshot here.

Wondering why I am seeing a single 1 in the Apdex score as well, if nothing is using this service.

Ok, so from the documentation, List application ID, host ID, instance ID | New Relic Documentation

If I am using this command -
curl -X GET ‘https://api.newrelic.com/v2/applications/$APP_ID/hosts.json
-H ‘Api-Key:$API_KEY’ -i

and I use my API_KEY, I get some output that I am interpreting as - This application has no hosts!

Can you please verify this is correct, that this application is not present on any hosts? If that is true, how can I remove this “My Application” from my Dashboard?

{
“applications”:[
{
“id”:1217714340,
“name”:“My Application”,
“language”:“dotnet”,
“health_status”:“gray”,
“reporting”:true,
“last_reported_at”:“2021-08-30T14:15:15+00:00”,
“application_summary”:{
“response_time”:0.0,
“throughput”:0.0,
“error_rate”:0.0,
“apdex_target”:0.5,
“apdex_score”:0.0,
“host_count”:0,
“instance_count”:0
},
“settings”:{
“app_apdex_threshold”:0.5,
“end_user_apdex_threshold”:7.0,
“enable_real_user_monitoring”:true,
“use_server_side_config”:false
},
“links”:{
“application_instances”:[

        ],
        "servers":[
           
        ],
        "application_hosts":[
           
        ]
     }
  }

],
“links”:{
“application.servers”:"/v2/servers?ids={server_ids}",
“application.server”:"/v2/servers/{server_id}",
“application.application_hosts”:"/v2/application/{application_id}/hosts?ids={host_ids}",
“application.application_host”:"/v2/application/{application_id}/hosts/{host_id}",
“application.application_instances”:"/v2/application/{application_id}/instances?ids={instance_ids}",
“application.application_instance”:"/v2/application/{application_id}/instances/{instance_id}"
}
}

I keep wanting to draw a conclusion that there is no agent running on any hosts.

I keep seeing the Apdex score update daily:

Can I assume there are no Agents running on any hosts? I just don’t want to leave any agents or traces of New Relic in my Prod environment that are unaccounted for.

I don’t think I can assume there is not agent installed in my hosts -

It seems like it is loaded just once daily.

@derek.lyons Thanks for your screen shots and details here!

This appears to be a .NET APM application that is connected to a browser application with the same name, correct?

If you attempt to delete the APM application by following these instructions below, does it give you an error message or does it successfully remove it? If your browser application is linked to an APM application, deleting the APM application should also remove the browser application.

  • Click the Delete application button on the APM application/service’s Settings page. Go to one.newrelic.com > APM > (select an app/service) > Settings > Application.

It’s possible the frontend data you see still reporting on that html page could be a few things. Has the browser agent’s JavaScript been fully removed from any live html app pages? It’s also possible that it has been removed and this is end user caching, which we won’t be able to control (a user still has a web page on an open browser tab).

Thanks again,

1 Like

Thanks so much for the replies and help!

Unfortunately, when I went to that section to delete the application, it said the service is still reporting data to New Relic, so it can’t be removed.

I don’t understand how it knows data is still being reported to it, but we can’t figure out what host or application.

I didn’t update any HTML. I only tried the powershell commands to install the agent, the infra agent worked fine, but when I was trying to get the .net agent to work is probably how I got myself into this situation. I was trying different install method and none seemed to work.

Can you share a permalink to the app in New Relic?