Azure EventHub forwarder 403

Hi,

I’m trailling out NewRelic but I’m having trouble getting the EventHub log forwarding to work, I have an App Service pushing logs to the EventHub created by the NewRelic template, however, when the logs didn’t show up in the UI I checked the Function App the template created, and it has the following logs present:

2022-11-16T08:59:16.363 [Information] Host Status: {“id”: “nrlogs-eventhubforwarder-wkepjgi”,“state”: “Running”,“version”: “3.17.0.0”,“versionDetails”: “3.17.0 Commit hash: a2c47e3bd045f6b4eec138e144fa830368ed9426”,“platformVersion”: “99.0.10.730”,“instanceId”: “366fa4ceeaa7a4f625054606f1c6f18d1b76c9001231386e1284cf7dc8fb4e9a”,“computerName”: “10-30-5-250”,“processUptime”: 3664116,“functionAppContentEditingState”: “Unknown”,“extensionBundle”: {“id”: “Microsoft.Azure.Functions.ExtensionBundle”,“version”: “1.8.1”}}

2022-11-16T08:59:17.180 [Information] Executing ‘Functions.EventHubForwarder’ (Reason=’(null)’, Id=9d56c437-4306-431f-92dc-aea5482c5ce7)

2022-11-16T08:59:17.208 [Information] Type of logs: records Array

2022-11-16T08:59:17.298 [Information] Got response:403

2022-11-16T08:59:19.351 [Information] Got response:403

2022-11-16T08:59:21.437 [Information] Got response:403

2022-11-16T08:59:21.438 [Error] Max retries reached: failed to send logs payload to New Relic

2022-11-16T08:59:21.493 [Error] Error during payload compression

2022-11-16T08:59:21.543 [Error] Exception: {}

2022-11-16T08:59:21.592 [Information] Executed ‘Functions.EventHubForwarder’ (Succeeded, Id=9d56c437-4306-431f-92dc-aea5482c5ce7, Duration=4413ms)

I have tried the key that is auto generated by the log setup process, I have tried generating my own key, I have tried using my user key, none of them seem to work unless the 403 is a red herring.

Any help is greatly appreciated.

Hi @daniel.ribeiro1

Thanks for reaching out, I hope you are well.

Congrats on your first post in the community, Whoop!

Hummm this is tricky, I would suggest following the docs here Forward logs and activity logs from Azure. Ensure each step is followed, the issue looks permissions related as 403 usually relates to permissions. However I dont see any notable permissions issues.

If the issue persists please share a permalink to where you are expecting to see the log on the New Relic account as well as sharing any screenshots / snippets of the logs reporting.

I hope this was helpful, should you have any questions or updates please do reach out.

Also if this helped resolve the issue please consider selecting the Solution ( How to Use the Official Solution Checkbox )option below this post.

Hi @dcody

Thanks for having a stab at my issue.

I have followed the documentation as much as I can tell, unfortunately it still doesn’t narrow down where the 403 is coming from e.g. New Relic (which I assume it is) or something else. In the function app’s script, I can’t see any way of increasing the log verbosity, but then again I’m not that ofay with Node.js

Permalink to my New Relic instance - https://onenr.io/0BQrqPK86jZ

Can I confirm that the URL that the function app should be using to forward these logs on is https://log-api.newrelic.com/log/v1?

Thanks in advance.

Hi,

Here is the document Event Hub Forwarder, which has the example function.js and the screenshot of the setting related to Event Forwarder. Can you please re-check all the configurations?
https://github.com/newrelic/newrelic-azure-functions/tree/master/EventHubForwarder

I hope it helps.
Thanks,
Suman

Hi @sjyoti, I’ve taken a look at the github link and I can’t see any difference between what I have in Azure and the js files in that repo.

Is there any way we can see what’s happening New Relic side?

Hi @daniel.ribeiro1 ,
Do you have any network security. Can you please check if you are able to access https://log-api.newrelic.com/log/v1 . You may use the following command:

curl --location --request POST ‘https://log-api.newrelic.com/log/v1
–header ‘X-License-Key: XX33aX53X0aa852X4f3Xf3X13X982cee5114XXXX’
–header ‘Content-Type: application/json’
–data ‘{“message”:“Hello World”}’ -vvv

I hope it helps.
Thanks,
Suman

1 Like