Browser Application - unable to have application seen from apm service

,

I am unable to have a browser application be created in the account for an APM service.
APM service with browser timing headers injected: apm service
Public url with browser timing headers added

The reason why this is confusing is that I had just set up a similar apm service and had no issues having the browser application for it show up. Public url for this application that works.

I went through the troubleshooting doc and still do not see any difference.

The newrelic.js file looks like this (minus application name and license key). This file is identical in both the working and not working application except for the app_name

'use strict'
/**
 * New Relic agent configuration.
 *
 * See lib/config/default.js in the agent distribution for a more complete
 * description of configuration variables and their potential values.
 */
exports.config = {
  /**
   * Array of application names.
   */
  app_name: ['REDACTED'],
  /**
   * Your New Relic license key.
   */
  license_key: 'REDACTED',
  /**
   * This setting controls distributed tracing.
   * Distributed tracing lets you see the path that a request takes through your
   * distributed system. Enabling distributed tracing changes the behavior of some
   * New Relic features, so carefully consult the transition guide before you enable
   * this feature: https://docs.newrelic.com/docs/transition-guide-distributed-tracing
   * Default is true.
   */
  distributed_tracing: {
    /**
     * Enables/disables distributed tracing.
     *
     * @env NEW_RELIC_DISTRIBUTED_TRACING_ENABLED
     */
    enabled: true
  },
  logging: {
    /**
     * Level at which to log. 'trace' is most useful to New Relic when diagnosing
     * issues with the agent, 'info' and higher will impose the least overhead on
     * production applications.
     */
    level: 'info'
  },
  /**
   * When true, all request headers except for those listed in attributes.exclude
   * will be captured for all traces, unless otherwise specified in a destination's
   * attributes include/exclude lists.
   */
  allow_all_headers: true,
  attributes: {
    /**
     * Prefix of attributes to exclude from all destinations. Allows * as wildcard
     * at end.
     *
     * NOTE: If excluding headers, they must be in camelCase form to be filtered.
     *
     * @env NEW_RELIC_ATTRIBUTES_EXCLUDE
     */
    exclude: [
      'request.headers.cookie',
      'request.headers.authorization',
      'request.headers.proxyAuthorization',
      'request.headers.setCookie*',
      'request.headers.x*',
      'response.headers.cookie',
      'response.headers.authorization',
      'response.headers.proxyAuthorization',
      'response.headers.setCookie*',
      'response.headers.x*'
    ]
  }
}

My expectation is that this should just show up, and since the application that works is nearly identical to setup as the one that doesnt work, I am looking for guidance as to what my next steps should be.

@chris.jones2 Hi there! I wanted to confirm if you were still having this issue? From what I can see (and thanks for the level of detail here with links!), the browser application previously not displaying data is now here at least for the last 30 minutes.

Let us know what, if any, issues you may still be facing. And if not, what solved this for you? Thank you again!

1 Like