Your data. Anywhere you go.

New Relic for iOS or Android


Download on the App Store    Android App on Google play


New Relic Insights App for iOS


Download on the App Store


Learn more

Close icon

Earliest Version of .Net Version supported to use APM Agent


#1

Hi NR Team,

What is the Earliest version of .NET framework is supported to use the APM Agent?

How do I check the APM Agent’s current installed version?


#2

Hi @Manoj.Ravikumar -

You can use the Insights query below to see which agents and versions you have installed:

SELECT apmAppName, apmAppId, apmLanguage, apmAgentVersion FROM NrDailyUsage WHERE productLine = ‘APM’ AND usageType = ‘Application’ SINCE 1 day AGO

There are some details here on the framework versions - https://docs.newrelic.com/docs/agents/net-agent/getting-started/compatibility-requirements-net-framework-agent#net-version

Please note that as per this post: IMPORTANT: Upcoming Changes To Supported Agent Versions - .Net Agent Versions pre-5.1 will be EOL’d later this month.