Graphics not showing on dashboard

Hi !

Last days I noticed that some widgets from my dashboard are not showing activity at all:

But if I try to edit some of that, I can see the graphics must been saw in dashboard:

Below, I’m sharing the dashboard:

https://onenr.io/0oQD4lAX1Qy

Can you help me ?
Thank you !

Hi @eagarcia

Thanks for reaching out, I hope you are well.

I did a little digging and can confirm the following;

  1. All data and dashboards are reporting correcrtly.

  2. I noted that this part of your query “error.class” is root of the issue, all the data is correct but there is no data related to error.class, which is it shows no data in the dashboard.

  3. This query returns data as SELECT count(*) FROM TransactionError FACET error.class TIMESERIES WHERE appName = ‘channels-bo-partner-prod’ since 1 month ago

Please see screenshots for reference.

I hope this was helpful, should you have any questions or updates please do reach out.

Also if this helped resolve the issue please consider selecting the Solution ( How to Use the Official Solution Checkbox )option below this post.

Thank you, @dcody , but the case is that those widgets has been showing activity by months ago with the same query, but suddendly on this week them turned blank and nobody changes the query.
In addition, I have to say that the query is taken from APM-Error, please see this example:


On APM :arrow_up:


On my widget :arrow_up:

I mean… the widgets was working ok during months until a few days ago. I didn’t modified anything for at least one month ago, then, There are posibilities that something changed from your side ?

Hi @eagarcia - I believe this is a known issue with the use of IS and IS NOT. We have an open issue that we are waiting for an update from Engineering. I will try to get an update on Monday.

1 Like