Installing New Relic on Ubuntu 16 issues

We have been using New Relic to monitor a ton of our servers running different Operating Systems. But while installing NR agent on Ubutnu 16.4, I ran into this error.

initctl: Unable to connect to Upstart: Failed to connect to socket /com/ubuntu/upstart: Connection refused
dpkg: error processing package newrelic-infra (–configure):
subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
newrelic-infra
E: Sub-process /usr/bin/dpkg returned an error code (1)

I did see one other support question on the same topic, but the answers were definitely not clear there as the topic strayed towards Docker containers. I can confirm that the newrelic-infra.list has just

“deb [arch=amd64] https://download.newrelic.com/infrastructure_agent/linux/apt xenial main”

What could potentially be the issue? Any help here is appreciated, thank you!

Hi there!

Something does look like it went awry with your install. I would do the following:

Uninstall

  • sudo apt-get remove newrelic-infra – this may fail
  • rm-rf /etc/apt/sources.list.d/newrelic-infra.list

This should clean out Infra from the system. We can then try the install again.

  • curl https://download.newrelic.com/infrastructure_agent/gpg/newrelic-infra.gpg | sudo apt-key add -
  • printf "deb [arch=amd64] https://download.newrelic.com/infrastructure_agent/linux/apt xenial main" | sudo tee -a /etc/apt/sources.list.d/newrelic-infra.list
  • sudo apt-get update
  • sudo apt-get install newrelic-infra -y

Please let me know how it goes!

Regards,

Paul

I get message like this :

apt-get install newrelic-infra -y

Reading package lists… Done
Building dependency tree
Reading state information… Done
You might want to run ‘apt-get -f install’ to correct these:
The following packages have unmet dependencies:
linux-image-extra-4.4.0-119-generic : Depends: linux-image-4.4.0-119-generic but it is not going to be installed
linux-image-generic : Depends: linux-image-4.4.0-119-generic but it is not going to be installed
Recommends: thermald but it is not going to be installed
E: Unmet dependencies. Try ‘apt-get -f install’ with no packages (or specify a solution).

What happen this?

Hello, It does look lke you have some dependency issues. I see on your output that it suggests to run sudo apt-get -f install to correct that. You may want to try that.

You could also try installing the agent manually. You would download the “.deb” from here:

https://download.newrelic.com/infrastructure_agent/linux/apt/pool/main/n/newrelic-infra/newrelic-infra_systemd_1.0.898_amd64.deb

Then run: sudo dpkg -i newrelic-infra/newrelic-infra_sysv_1.0.898_amd64.deb

Hope this helps!

Paul

It worked. Thank You.

1 Like

Glad you were able to get installed :smiley: Thanks for letting us know