Kubernetes APM Integration Failing (Unsupported)

Hello,
I am running into this issue when trying to install the New Relic agent into my Kubernetes resources using the guided install. Here are the steps I am doing:

  1. Put in my Cluster Name
  2. Keep the namespace as newrelic (It wasn’t exactly clear if this is supposed to be a an existing namespace you want to monitor or a new namespace new relic would use to monitor. So I just left it as is)
  3. Checked off “gather log data” and “Reduce the amount of ingested data”
  4. Selected Guided Install from the drop down and copied the command I am supposed to run in my terminal

What happens when I run the command provided in step 4 is:
Installing New Relic Kubernetes Integration

Installation Summary

⊘ Kubernetes Integration (unsupported)

Installation incomplete. Follow the instructions at the URL below to complete the installation process.

https://onenr.io/0MRNmpNJ2wn


We encountered an issue during the installation: no recipes were installed.
If this problem persists, visit the documentation and support page for additional help here at https://one.newrelic.com/-/06vjAeZLKjP.

There is nothing specific shown as to why it isn’t supported unless there is a verbose style flag I can include to see exactly where it is failing.

Some additional information:
I do not use Helm
The account tied to my kubectl cli has ownership status on the project
I integrated with a GCP project using the recommended service account for the project integration
My account is a free tier. However, I have “Full Platform” status access

@cullen I have checked your account and it looks like you've exceeded your free tier limit. You could perhaps extend it for another 7 days or you could add a credit card to unlock access beyond the free tier. Here is the message that I am seeing under your account:

You’ve exceeded your free tier limit. Please add a credit card to unlock access beyond the free tier.

  • You’ll get the same free tier every month. 100GB free data ingest, 1 free full (standard) user, unlimited free basic users.
  • You’ll only pay for what you use above your free tier limit. $0.25 per additional GB. $99 per additional full (standard) user added.
  • You can cancel anytime, and always have full control to manage your usage.
1 Like

same problem here… i’m on a k3s cluster hosted on a hetzner ubuntu vm, i tried both privileged and unprivileged install type, both say Kubernetes Integration (unsupported)
i’m on a lifetime free account, just got it thanks to kubecon offer

Hey there @a.fragola,

Welcome to the community!

I believe you are seeing this due to the same reason as listed above. I looked into your account and it shows that you have utilized 99.90% of your monthly free data limit. With that said I am bringing in an engineer from our Infrastructure team to look into this further with us and hopefully provide a solution.

Please let us know if there is anything else we can help with and we will be happy to assist. We appreciate your patience as we work through this with you as well. I hope you have a great day!

Hello @cullen and @a.fragola, in addition to checking free tier limits as mentioned, you can also try other installation methods.

The CLI script (“Guided Install”, the default method) will run a bunch of checks to be totally sure the environment is supported. If it finds a less common environment such as a homebrewed cluster or k3s, it may not pass the checks (We’re working on official k3s support).

To work around this, you can use either the Helm or Manifest install methods, by choosing them from the dropdown at the last screen of the Guided Install where the install command is provided. The CLI uses these methods under the hood, checking for the presence of Helm first, using Helm if possible - then if Helm is not available it will install via manifest.

If you’re interested, you can view the logic which the installer script is using here, and file issues on our open-install-library Github repo: https://github.com/newrelic/open-install-library/blob/main/recipes/newrelic/infrastructure/kubernetes.yml