Logs not available

Hi

I would like to see my logs in https://one.eu.newrelic.com/launcher/logger.log-launcher but i only see " Get started by connecting your logs to New Relic" message.

I’ve installed on my server logstash, logstash-newrelic plugin and evrything else from the docs.

In /var/log/logstash/logstash-plain.log i can see that it’s up and running:

[2020-12-23T22:16:25,687][INFO ][logstash.javapipeline ][main] Starting pipeline {:pipeline_id=>“main”, “pipeline.workers”=>2, “pipeline.batch.size”=>125, “pipeline.batch.delay”=>50, “pipeline.max_inflight”=>250, “pipeline.sources”=>["/etc/logstash/conf.d/psibufet.conf"], :thread=>"#<Thread:0x4654897b run>"}
[2020-12-23T22:16:27,162][INFO ][logstash.javapipeline ][main] Pipeline Java execution initialization time {“seconds”=>1.43}
[2020-12-23T22:16:27,845][INFO ][logstash.inputs.file ][main] No sincedb_path set, generating one based on the “path” setting {:sincedb_path=>"/var/lib/logstash/plugins/inputs/file/.sincedb_b9e1c17a0710cc56250822fd207ded53", :path=>["<PATH TO MY LOG FILE>"]}
[2020-12-23T22:16:27,905][INFO ][logstash.javapipeline ][main] Pipeline started {“pipeline.id”=>“main”}
[2020-12-23T22:16:28,022][INFO ][logstash.agent ] Pipelines running {:count=>1, :running_pipelines=>[:main], :non_running_pipelines=>[]}
[2020-12-23T22:16:28,039][INFO ][filewatch.observingtail ][main][d1f48ff07abfb07501ba9082e68a816f7f990dcb703641d1f5e474d5476ee4d3] START, creating Discoverer, Watch with file and sincedb collections
[2020-12-23T22:16:28,457][INFO ][logstash.agent ] Successfully started Logstash API endpoint {:port=>9600}

but nothing is shown.

WHat else i can check ?

In https://logz.io/ it’s extremely simple. You only need to add appender to your logback.xml file and that’s it.

Can you run this query using the New Relic Query Builder and see if it returns any data? If it doesn’t return anything that means your logs are not coming in to New Relic so we’ll need to first debug the connection.

Select * from Log

I cannot even see any panel for checking this.

It’s redirecting me to this screen

Hi @kontakt16, what you could do is write your logs to stdout instead of writing to a log file. This is useful for debugging purposes.

For more information please refer to Logstash documentation here: https://www.elastic.co/guide/en/logstash/current/plugins-outputs-stdout.html

Please let us know if that helps in resolving the issue. If the issue persists, could you please attach the Logstash debug logs with your response?