Your data. Anywhere you go.

New Relic for iOS or Android


Download on the App Store    Android App on Google play


New Relic Insights App for iOS


Download on the App Store


Learn more

Close icon

Missing instrumentation on a server

net-core-agent

#1

Some applications are not instrumenting properly. I did try troubleshooting with nrdiag and process explorer with no luck.

.net core applications stopped instrumenting to be more specific. I did re-install the most recent version but not sure what went wrong. When I click on the process in process explorer I do not see any dll’s


#2

@teja.mudhunuri

Your .NET Core applications stopped instrumenting, is it possible that some require environment variables has been overwritten or something else is preventing from the New Relic Agent from profiling, we recommend following this Community Post, do let us know if you have gone through it already.

For .NET Core, you must configure your application to be monitored by setting the following
CORECLR_ENABLE_PROFILING=1, for other environment variables needed (which should be set with the latest version of the .NET), see this link.

Also, see our troubleshooting guide for app(s) that have stopped reporting data to APM.
https://docs.newrelic.com/docs/agents/net-agent/troubleshooting/no-data-appears-net

FYI: We have seen cases where the app is .NET Core but it’s targeting the .NET Framework, see below Community Post which may not apply to you but it’s something to keep in mind.

Do let us know how you get on and also can you share the permalink of your app, please?