Relic Solution: Profiler log says ".NET Framework 4.5 is required"

This post is part of a series of posts designed to guide you through troubleshooting common issues in the .NET agent. For more context, please see the .NET Agent not reporting troubleshooting guide>.

The issue

  • The .NET agent profiler log for your application’s process says .NET Framework 4.5 is required.

What it means.

  • The application you’re trying to monitor was built on .NET Framework version 4.0 or lower.
  • The version of the New Relic .NET agent you have installed only supports applications built on .NET Framework 4.5 or higher.
  • Note: This message has nothing to do with the version(s) of .NET Framework that are installed on the server. It is in reference to the .NET Framework that the monitored application is built on.

The solution

Why it works

  • The New Relic .NET agent dropped support for .NET Framework 4.0 and lower in version 7.0. If your application is built on one of these framework versions, the newest 6.x version of the agent is the most current version that can monitor your application.

Official Documentation

1 Like