Your data. Anywhere you go.

New Relic for iOS or Android

Download on the App Store    Android App on Google play

New Relic Insights App for iOS

Download on the App Store

Learn more

Close icon

Shouldn't 'America/Chicago' be central timezone?


###Shouldn’t ‘America/Chicago’ be central timezone?

  • I find that I have to use “WITH TIMEZONE ‘Etc/GMT+4’” to align with Central, but we are +6.

What am I doing wrong?


Are you sure? I just checked. When I compare the two they are the same and correct.

SELECT count(*) FROM Transaction with TIMEZONE 'Etc/GMT+6' since today facet hourOf(timestamp)

SELECT count(*) FROM Transaction with TIMEZONE 'America/Chicago' since today facet hourOf(timestamp)


My apologies, I misrepresented by saying Insights. This was in the alerting where I came across this.


The timestamps don’t align with the 6:00 start time


Try putting a “since” in there to make the request set wider .


Hey @6MM - This issue appears to be in NRQL Alerts, where SINCE clauses will not work.
I’ve passed this post on to both our Insights and Alerts support teams though, so I hope for their update shortly.


Thanks Ryan. I look forward to seeing their response, I’m glad I noticed the error.


Out of curiosity, what would be the purpose of using timezone in an alert. Are you essentially trying to simulate an alert downtime for violations at an off hour?


@reopelle.scott What timezone are you viewing these charts from? I can only speak for the Insights UI, but in Insights the query is always displayed in the timezone of the end-user running the query. The WITH TIMEZONE clause only affects the time period that the query looks at, not the way in which it’s displayed. I can’t say for certain if the behavior is the same in the Alerts UI, but my guess is that it is.


I checked my preferences and I guess I never set it to the Central timezone. HOWEVER, after changing this it got worse. Now it shows 10am on the chart with the same NRQL (aside from changing the ‘WITH TIMEZONE’ setting).


Because I can shut off data outside of the times when the activity is valid for alerting. The team I am working with does not want to be alerted about response times that are outside of the times they have customers. The alerting interface does not provide time period customization to specify when alerts should or should not be sent.


Gotcha. Just as I assumed. We use pagerduty to manage the process related to managing events. Pagerduty like so many similar systems permits scheduling and priorities. By using another tool for such things you have a greater degree of flexibility for silencing alerts. We can limit notifications through the evening, but also have them queued up in the morning for review.

We also use Datadog for alerting and that system offers similar flexibility on muting alerts on schedules.

I think it’s clever to try to simulate this with the timestamp check


Hi @reopelle.scott, just wondering if you got everything you need from @6MM’s response? :slight_smile:


He didn’t provide a solution, just some additional discussion. @RyanVeitch passed this post on to both our Insights and Alerts support teams and is waiting for an update.


Hi @reopelle.scott,

This sounds like an issue that we’ll need to dig into more deeply to discover what’s actually going on. To that end, I’m going to open a support ticket so that we can work together to investigate this.

Once the ticket has been solved, I’ll endeavor to repost the solution here so that the community can follow along and share any possible solutions we come up with.


I look forward to hearing about the solution.


@reopelle.scott it looks like @Fidelicatessen has opened up a support ticket for you to work on this, it would be great to hear how you get on :slight_smile: