Whitespace removed

I have a value.json file with entry:

{“RefreshHold”: “March 28, 2022 22:02:14”}

I have a flex integration that processes the json file as below:


integrations:

  • name: nri-flex
    interval: 120s
    config:
    name: refreshHold
    apis:
    - name: refreshHold
    file: value.json

The output is NRQL has no spaces as:

March28,202222:02:14

Why are the spaces removed? I want to see the output as March 28, 2022 22:02:14

Hi @r.balakrishnan1 - The documentation states that dates and times should be supplied as a Unix timestamp.

For attributes that contain date information, use an unformatted Unix timestamp in the Insights data formatter. You can define the date attribute either in seconds or in milliseconds, both relative to the Unix epoch.

1 Like

Thanks @stefan_garnham That worked!

@r.balakrishnan1

I hope you are doing well, its amazing to see you very first post in the community. Im so happy to see the supported offered has worked.

Also thanks to the community hero @stefan_garnham for the support, great job as always ( not all heroes wear capes ) :100: :sunglasses: :innocent:

2 Likes